Page 3 of 5 FirstFirst 12345 LastLast
Results 61 to 90 of 121

Thread: 80's Cool +boost

  1. #61
    Nay sayer Mr Ed's Avatar
    Join Date
    Aug 2005
    Location
    Canberra
    Posts
    15,093
    Noice one! Funny you dont want the gold wheels as theyre exactly what i want on my white one. Id offer to buy them but i need 5 stud
    #WHOTW award winner #blessed #susanalbumparty

  2. #62
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    You dunce they are 5 stud.

  3. #63
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Been troubleshooting the over 4500rpm miss and surging at light throttle, most likely culprit is the TPS, I have a TSRM guide to follow which I will do so soon but in the mean time i've ordered some coil packs, pig tails and will pick up some plugs too and it looks like a new radiator too possibly ex japan as no one has heard of a jza70 supra apparently which is what donated its heart to the ma61;





    Not looking to do an aluminum rad hopefully I can find one somewhere.

  4. #64
    Registered User dnegative's Avatar
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    4,397
    MA70 should be the same mounting and hose location wise; issue will be the mounting bosses for the hydrofan.

    If the core is ok, maybe just change the tanks and orings
    Quote Originally Posted by cracka View Post
    Fuck I'm retarded

  5. #65
    Registered User dnegative's Avatar
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    4,397
    Quote Originally Posted by cracka View Post
    Fuck I'm retarded

  6. #66
    Nay sayer Mr Ed's Avatar
    Join Date
    Aug 2005
    Location
    Canberra
    Posts
    15,093
    A70 and A60 radiators are different widths from memory. I have a photo somewhere comparing them.

    Quote Originally Posted by kedderz View Post
    You dunce they are 5 stud.
    Yeah dunno how I missed that. So this means I want your wheels and you should give them to me.
    #WHOTW award winner #blessed #susanalbumparty

  7. #67
    Nay sayer Mr Ed's Avatar
    Join Date
    Aug 2005
    Location
    Canberra
    Posts
    15,093
    Heres a post about the different radiators: http://www.performanceforums.com/for...#post841610553

    Theyre more similar than I remembered, A70 is a bit taller so yeah you likely have a JZA70 radiator there. (MA70 has different pipe locations)

    S13 radiator should also fit, which might make the search a fair bit easier. I have an S13 radiator in mine.
    #WHOTW award winner #blessed #susanalbumparty

  8. #68
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Thats not a jza70, its an 80.

    Some internetting has advised that the hyfrofan setup is more central on the jza70, 1 mounting tab is different on the ma70 so they arent really compatible and the hydro temp sensor boss is missing as well.
    Top and bottom end tanks I cant find a part number for on the jza70, all the sites I usually use that part in an exploded diagram has no part number else id just order that and get the local mob to redo the tanks.

    Ed - Not after an aluminium setup, the engine bay is too neat to china it up
    Its a jza70 rad + hyrdro fan setup straight from the halfcut.

    I've sent a few links I found to streeter to see if he can liase with any of the jap companies or knows of a place that can make one up, he's usually pretty good/knowledgeable.
    Last edited by kedderz; 20-10-16 at 10:33 AM.

  9. #69
    Registered User TRD-MX62's Avatar
    Join Date
    Jun 2014
    Location
    melb
    Posts
    1,911
    just go a china radiator, smooth the welds back and hit it with some semi gloss black

  10. #70
    Nay sayer Mr Ed's Avatar
    Join Date
    Aug 2005
    Location
    Canberra
    Posts
    15,093
    Yeah I wasnt showing you because aluminium, just for size comparison.

    Didnt realise it was hydrofan, thats a bit of a cunt, but the brackets on those are a pretty simple thing. You could adapt it to an S13 radiator if the search ran into a dead end. S13 parts are alot easier to get.
    Last edited by Mr Ed; 20-10-16 at 10:38 AM.
    #WHOTW award winner #blessed #susanalbumparty

  11. #71
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Yep I've just started the search so seeing what I can get and if all else fails I can always change the water pump/fan setup over as well and put in some au thermos and a s13 rad setup.

  12. #72
    Registered User dnegative's Avatar
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    4,397
    MA70 hose locations are mint, that's what I have in my MA61/1JZ

    Getting the hydro bolted on though...

    Keep the hydrofan, they are awesome, you can skid the thing up a mountain in summer and the 4500cfm they pull will keep it in check
    Last edited by dnegative; 20-10-16 at 11:01 AM.
    Quote Originally Posted by cracka View Post
    Fuck I'm retarded

  13. #73
    Registered User TRD-MX62's Avatar
    Join Date
    Jun 2014
    Location
    melb
    Posts
    1,911
    Quote Originally Posted by dnegative View Post
    Keep the hydrofan, they are awesome, you can skid the thing up a mountain in summer and the 4500cfm they pull will keep it in check
    This, Hydrofan is the way to go.

  14. #74
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Hydro isnt going anywhere, streeter has come through and a koyo copper 2 row oem replacement which will do nicely.

  15. #75
    Owns a bucket no13b_Coupe's Avatar
    Join Date
    Mar 2012
    Location
    Canberra Nth
    Posts
    3,377
    Ahh man look seriously. Cunts fucked.

    No point fixing it.

    I got a mate in Adelaide these days with a trailer PM me your address and bank details. I'll get him around tonight.

    Don't stress about the radiator I'll fix it.

    BF XR6 Turbo - 2L Turbo TE - 75 TX Coupe - Atlas SS

    - PSN: rotacoupe

    This is obviously assuming all your AUX outputs are doing something. Ie idle control, and the other does water spray, and the other updates your Instagram automatically etc.

  16. #76
    Registered User schnitzelburger's Avatar
    Join Date
    Jan 2003
    Location
    syd
    Posts
    2,952
    S13 alloy ebay rads go in pretty easily

  17. #77
    Nay sayer Mr Ed's Avatar
    Join Date
    Aug 2005
    Location
    Canberra
    Posts
    15,093
    Why does it need a new radiator anyway?
    #WHOTW award winner #blessed #susanalbumparty

  18. #78
    Opens pp's Avatar
    Join Date
    Aug 2002
    Location
    Gold Coast
    Posts
    1,152
    That is very tidy and so cool - so miss mine - was about the same level of tidyness. I am now tempted to buy it back as one of my staff knows of its whereabouts .... enjoy!!
    CU in the forest ... sideways!
    --

  19. #79
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Quote Originally Posted by Mr Ed View Post
    Why does it need a new radiator anyway?
    Check the pics, end tanks are EOL and I cant find any tanks to just redo them so I bought an upgrade.

    no13b_Coupe - yeah I'll just burn it, too much hassle

  20. #80
    Owns a bucket no13b_Coupe's Avatar
    Join Date
    Mar 2012
    Location
    Canberra Nth
    Posts
    3,377
    nnnnnnoooooooooooooooooooooo!!!!

    Come back to the ACT for skid pan one time I can admire.
    BF XR6 Turbo - 2L Turbo TE - 75 TX Coupe - Atlas SS

    - PSN: rotacoupe

    This is obviously assuming all your AUX outputs are doing something. Ie idle control, and the other does water spray, and the other updates your Instagram automatically etc.

  21. #81
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    So looks like the front cut that donated its heart was an auto because the PO use the tranny cooler inbuilt to the old rad as a PS cooler, did ma61's have PS coolers? Ive asked streeter to see if the KOYO rad can come as an auto rather than a 5MT unit but I'm doubtful so may have to add a PS cooler if they came with one from factory.




  22. #82
    Registered User schnitzelburger's Avatar
    Join Date
    Jan 2003
    Location
    syd
    Posts
    2,952
    Ma61 had a hard line doing a loop approx 200mm out the front of the air con condensor as stock. Thats as much of a psteer cooler they had

  23. #83
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Quote Originally Posted by schnitzelburger View Post
    Ma61 had a hard line doing a loop approx 200mm out the front of the air con condensor as stock. Thats as much of a psteer cooler they had
    Thanks, thought that might be the case.

    Other thought is it could be for the hydrofan setup, I had kids screaming right at the end of the 10 minutes I had spare to do this so I cant remember exactly where the lines went from/to.

  24. #84
    Registered User
    Join Date
    Jul 2003
    Location
    Adelaide
    Posts
    3,659
    I used a Cressida radiator in my ma70+1jz at the JZA70 one had perished end tanks. A radiator shop in Mt Barker put it in and I can't remember how they mounted the fan.

    It didn't have a boss for the temp sensor though - we were going to put one in the pipe going into the radiator but never got around to it (instead just plugged the fan controller in and it ran the fan at max speed without the temp input). I was usualy going at max speed any time I drove it so I figured it wouldn't hurt.

    PS cooler lines are usually just a loop of hardline hanging in the front bumper somewhere.
    Marvellous things so quickly get mundane

  25. #85
    Registered User
    Join Date
    Aug 2011
    Location
    Perth
    Posts
    422
    Is PS fluid meant to run at engine temps?

  26. #86
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Dunno, is it ?

    Got the rad out this arvo, coils and throttle to check the tps.

    First reading ok, just



    Second, not so much at all moving the tps doesn't put it in spec at all and just goes to infinite most of the adjustment.....



    So now sits like this waiting for the parts to arrive. Gtr should get more attention....


  27. #87
    Registered User my limp penis's Avatar
    Join Date
    Nov 2010
    Location
    Victoria
    Posts
    949
    oh well hello there, this is all sorts of win
    '84 Supra 7MGTE
    '86 Supra 2JZGE track
    '99 Supra GTX35 VVTi
    '10 C63 AMG


    PSN: RyleyMA61

  28. #88
    Registered User my limp penis's Avatar
    Join Date
    Nov 2010
    Location
    Victoria
    Posts
    949
    Got any brake set up pics? Starion clear my calipers (326mm with Z32) by maybe 2mm. Only due to the brakes mounted to the rear of the hub. The spokes have fuck all calipers clearance.

    What 5 stud swap is it?

    I reckon that decal on the hatch is from my first reproduction run about 10 years ago.. I wonder who the seller was

  29. #89
    Registered User
    Join Date
    May 2007
    Location
    ACT 2607
    Posts
    1,901
    Bam, koyo rad, new coil packs, tps (what a shit to calibrate properly) and coil pack wiring all done.



    Next to do is the caps in the ecu as cold start is still non existant but hot start is fine....


  30. #90
    Registered User dnegative's Avatar
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    4,397
    1jz's should fire within a split second of hitting the key when cold, would 100% check the ECU, JZA70 computers all had shitty caps. Later JZZ30 ones not as much
    Quote Originally Posted by cracka View Post
    Fuck I'm retarded

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •