Announcement

Collapse
No announcement yet.

13/04/1300 Mazda 626 Turbo

Collapse
X
Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I have never seem this thread before - fucking speechless.

    So much awesome shit, well done.

    Comment


      agreed. top notch work, fab work is excellent.
      https://www.facebook.com/Petes-Weldi...7343264035404/

      Comment


        thanks guys

        spent a few nights this week driving the Mazda around trying to find a road tuning spot. i'm such a fucken pussy; i'd find a spot but there would be either too many cars or it would be too close to houses. i've had cops called on me before and it is not fun, especially when you're kicking around in a defectable vehicle. i guess the powers that be would rather us sitting down watching TV then pursuing our hobbies / challenging ourselves.

        anyhow, bit the bullet, went to bed early and set the alarm for midnight for a early morning power run tuning session. with a relatively remote (but central!) spot identified i got to work. the spreadsheet i made to make the logs more user friendly worked awesomely. i worked up from 5 to 10 to 15PSI. ignition curve was a 'theoretical' one entered perviously and didn't need modifying at this point in time. did 3rd gear pulls. had rev limiter set to 7500rpm but the thing didn't want to rev much past 6000rpm (???). targeted 12:1 AFR under boost and worked up to it from richer AFRs.

        towards the end of the night i had the tune at prob 11.7:1 AFR under boost and trimmed a little fuel out to hopefully get to the 12:1 AFR target. started the 3rd gear pull and under load it missed 3 or 4 times. analysed the log and it was good except for leaning out around the misses for whatever reason. did another pull and boost came on quicker than before, hence hitting parts of the map that were previously tuned leaner. immediately after this lean out onto boost there was heavy missing. i pulled over and added a heap of fuel everywhere. same result though: put foot down and boost comes on very quickly and missing starts soon after and the car feels like you've just hit the brake, not the accelerator.

        haven't had a chance to look under the bonnet yet. i'm guessing it is my ignition system fucking up. there are only so many components to it so i'll go through them one by one. if anyone else has had/heard of similar issues or thinks they know what it could be please let me know!

        Comment


          whats boost and rpm like? my setup i think i made 2-4 psi in first total by 5000rpm. then 8 in every other gear by 4500.
          no chance it will make power past 5000rpm, tune for bulk torque. these are tractor motors. dont rev it
          caprice nugget.

          Comment


            Yeah no chance of revving it hard, it just wont happen without some big head work.

            I used to have a similar high boost miss which I could never figure out even on the stock ecu. Played around with plugs and leads and it never made much difference.
            POWER CHIP free since 2003.

            Comment


              yeah, with peak torque (at 15psi) happening at about 4krpm and fuel requirements dropping off there after i wasn't really expecting to use much more than 6krpm before changing gears anyway. i guess i was kind of caught by suprise that it wouldn't rev out to the redline point on the factory tacho.

              E-Z haven't done any second gear (or first gear) pulls yet. second gear power runs seems to go too quick even though i'm sure i'd have the traction to do it at this point in time.

              third gear makes 15psi at 4250rpm according to this old log that i found from the other night (prior to sorting out AFR in the top end... and prior to epic miss issue)

              Comment


                issue turned out to be a loose nut on the body ground collection point. forgot to tighten the nut during installation and it gradually loosened to the point at which Burgess became undriveable.

                tightened nut and all is good. celebration (non skid) vid to come.

                Comment


                  Edit: links deleted.

                  Can't wait to see if it does 13's!

                  Comment


                    thanks Damo. thanks for your help today too.



                    Comment


                      TAKE THAT! You fucken intercooler!

                      Can't wait to see what this does at the track
                      Previously known as Lobster, Chuss's brother's anus, Chuss's brother, Lobsook, Lobstersock, Socks, Sockz, MissAmericaImportGirl, ClutchCLobster

                      CJM 4 Life yo!

                      Comment


                        lol fuck the cooler. sounds good, boost is impressive
                        caprice nugget.

                        Comment


                          i thought with the car being 2 foot off the ground and all that the intercooler clearance wouldn't be a problem. was wrong but no fucks given.

                          Comment


                            I found a piston and rod out of one of these engines at home, the rod is very beefy, maybe about 50% larger cross sectional area that a early 90's twin cam 626 one I had it next to.

                            Comment


                              Cool! Rod looks beefy. How strong does the piston look (don't know jack about them)?

                              Comment


                                Originally posted by bumcrack View Post
                                issue turned out to be a loose nut on the body ground collection point. forgot to tighten the nut during installation and it gradually loosened to the point at which Burgess became undriveable.

                                tightened nut and all is good. celebration (non skid) vid to come.

                                I told you they are cranky about their earths haha

                                Comment

                                Working...
                                X