Announcement

Collapse
No announcement yet.

XP falcon deluxe coupe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ah sweet. I spoke with that guy ages ago.

    No mods to xp, staying 100% original. In fact I bought another commodore to tinker with. Ha.

    Sent from my HTC One M9 using Tapatalk

    Originally posted by 50RTD
    Dave, have you uploaded the data from the carby?
    Originally posted by Dogsballs;n7259704
    Bit harder to Wank to without Wendy, but got there in the end

    Comment


      Yeah man Reader's Rides...didn't think they tell you what month it's in the mag unless feature car.

      Fuck remember when there used to be several top car mags now Street Machine is only one left.
      Last edited by gtrboyyy; 29-07-21, 01:55 AM.

      Comment


        Found another owner. Eden Brinley, sold in 2014 for $14k

        Spats and visor are too much for me

        Sent from my HTC One M9 using Tapatalk

        Attached Files
        Originally posted by 50RTD
        Dave, have you uploaded the data from the carby?
        Originally posted by Dogsballs;n7259704
        Bit harder to Wank to without Wendy, but got there in the end

        Comment


          Agree the visor and spats unbalaces the coupes looks.

          Coupe visors are different to sedans/wagons and uber rare - if you still have it..


          efit - wonder if that's a sedan visor bodged on -doesnt really sit correctly
          Last edited by 9triton; 05-08-21, 04:05 PM.

          Comment


            Still been chasing this weird dieing at lights when it's hot.

            Pulled the carb top off and checked float level. It was a bit low at 1 1/8", compared to 15/16 to 1" for spec. So adjusted that. Also noticed the hot idle vent rod was also out of sync so bent tab on top of accelerator pump.

            Took it for a drive , still doing it, cunt. Came back and checked if vacuum fucks around when pressing brakes. No change. Hmm. Sprayed brake clean around all vac hoses to booster and also around carb, no change either.

            So went back and dialled up idle a bit. Seems to help. I found if I give it a smidge of choke or shift into neutral coming to lights I have no problem.

            Sent from my HTC One M9 using Tapatalk

            Attached Files
            Originally posted by 50RTD
            Dave, have you uploaded the data from the carby?
            Originally posted by Dogsballs;n7259704
            Bit harder to Wank to without Wendy, but got there in the end

            Comment


              Is it dieing as you come to a stop? Or after idling for a while.

              The auto carbs have two 'accelator' pump diaphrams.
              The one closest the rocker cover is the actual accelartor pump.

              The one facing the drivers inner guard is actually a dashpot to slow the return to idle.

              Was only on autos to stop them stalling when taking foot off accl as you came to a stop.
              Manual dont have ( but doesn't hurt them).

              There is a procedure for setting both.


              And maybe it has a hole ???


              Or try bumping the dist advance a few degrees at a time.

              Last edited by 9triton; 14-08-21, 09:27 PM.

              Comment


                Only has the one accelerator pump. Ahh that could be the issue.

                Only dies as you come to stop at lights. Idles a little rough then bam. Can catch it and then will be fine, gently easing off pedal

                Sent from my HTC One M9 using Tapatalk

                Originally posted by 50RTD
                Dave, have you uploaded the data from the carby?
                Originally posted by Dogsballs;n7259704
                Bit harder to Wank to without Wendy, but got there in the end

                Comment


                  Antistall dashpot in pic

                  If only has one on rocker cover side then its a manual carb
                  Click image for larger version

Name:	1100_components.jpeg
Views:	94
Size:	512.7 KB
ID:	7282022

                  Comment


                    Bummer. Adjusting choke trick will have to do

                    Sent from my HTC One M9 using Tapatalk

                    Originally posted by 50RTD
                    Dave, have you uploaded the data from the carby?
                    Originally posted by Dogsballs;n7259704
                    Bit harder to Wank to without Wendy, but got there in the end

                    Comment


                      Originally posted by Dogsballs View Post
                      Only has the one accelerator pump. Ahh that could be the issue.

                      Only dies as you come to stop at lights. Idles a little rough then bam. Can catch it and then will be fine, gently easing off pedal

                      Sent from my HTC One M9 using Tapatalk
                      Yeah dashpot is to slow the return to idle.

                      Can probably get around it by setting idle higher , bit more static advance, and twiddling mixture

                      Comment


                        It used have like 18-19 degs of static advance, still died. But could see timing right to base of ground strap on plug. Which is why I pulled it back to 12 as in spec

                        I run the idle mixture 0.5 turn back from stumbling (also max vacuum). Is it going lean? Should I dial it 0.5 in from stumbling rich?

                        Sent from my HTC One M9 using Tapatalk


                        Last edited by Dogsballs; 14-08-21, 09:40 PM.
                        Originally posted by 50RTD
                        Dave, have you uploaded the data from the carby?
                        Originally posted by Dogsballs;n7259704
                        Bit harder to Wank to without Wendy, but got there in the end

                        Comment


                          Yeah 12 to 14 about right for the autos

                          Maybe bump up the idle a
                          To 650rpm and mixture see what happens.

                          Comment


                            If you go searching for an auto carb. You need a 170 one.
                            they 'should' have a triangular aluminium tag with some id numbers.
                            Usually its lost..
                            But if need the xp ford id numbers let me know

                            Comment

                            Working...
                            X