No announcement yet.

Fuel pump issue - seriously weird, help needed!

  • Filter
  • Time
  • Show
Clear All
new posts

    Fuel pump issue - seriously weird, help needed!

    OK, so I did a fuel pump change yesterday. Everything went well. Started the car, it worked, all good. Then when I went to go somewhere, it idled for maybe 30 seconds, then died.

    Car is a 1989 BMW E34 535i. Here's what I've checked:

    1. Fuel pump relay working
    2. Fuses OK
    3. Getting power to the fuel pump harness connector in the boot with the key one click from starting
    4. Battery is good
    5. Every fucking other thing on the car works
    6. Switched ECUs - no difference

    What I have verified:

    1. Plugging in the sender assembly (which uses the same connector as the one for the in tank pump) - it works, shows full and empty
    2. Again, power is getting to the connector
    3. Fuel pump is not broken (verified by running an alternate 12v source through it, spins like a champ)

    So what happens is that every time you add a circuit to this connector, it drops voltage. Hook up the pump directly? Voltage drops to zero, pump doesn't work. Hook up a test light? Voltage drops to 7.5v.

    I've had a mobile 24/7 auto sparky out, and he couldn't figure it out. I'm totally stumped. Help please!

    Sounds like you have disturbed a poor contact (corroded etc) and made it worse or broken all but ~1 wire strand in a loom or something and the resistance of the loom doesn't allow current to flow to the load you are applying. Or the relay which drives it has failed in such a way that power is only getting through the relay driver coil rather than the main contacts? Battery voltage isn't pulling stupid low when you try to run is it?

    Got a spare thermo fan or something that can draw a bit of load you can connect to the pump relay/connectors to test under load?

    Doesn't run a low speed fuel pump resistor pack? That could cause weird problems if failed internally too.

    Ghetto solution, if you are using aftermarket ecu you could swap the trigger output for the pump relay so it wasn't on an engine run timeout logic, (just a general digital out and on the key on state, or attach a temporary earth to chassis from the relay trigger with ignition on if factory ecu) and short circuit the pump power at its connection terminals and wait for the smoke to come out if you have to replace the problem bit anyway :D


      check the earths... make sure the tank is tight if it earths through the tank.


        We ghetto fixed it... what must've happened was that the new pump draws more amps than the factory unit, and the wiring failed before it hit the fuse. It's the only logical explanation. Rather than tear the loom apart looking for a wire to replace, we used the original trigger wire on the FP relay to drive another relay under the back seat with separate wires out to the FP, which I will have to creatively get into the pump inside the tank.

        Tested the pump along the full new wiring loom outside the tank, and it performed exactly as it should. Will chuck it in in the next day or two and then we should be happy days again!


          Do some min/max logging on the fuel pump voltage to confirm the pump is getting what is should.. This can be done with most multimeters.