Announcement

Collapse
No announcement yet.

LS1 or LS2/L98 into 63 Belair

Collapse
X
Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 10sec rx7
    replied
    Do you really think cutting the end is going to put it out of balance? Lol... the shaft is 1in in dia not 1in long, removing the end of it is not gong to change the balance of it..

    It's pretty hard to get a t400 yoke that's right.

    Leave a comment:


  • Dean 560 SEC
    replied
    The output shaft is a lot longer than an inch - even the end section that would need to be removed is longer than that. As for how could cutting this off with a grinder cause the end of the shaft to be out of balance...I'll leave this alone.

    Problem solved - Ive ordered a Sonnax 3 bolt adapter flange yoke from Jegs in the US which will arrive late next week. $240 including express shipping from the US is a better option than stuffing around cutting output shafts and sourcing a correct length TH400 yoke.

    Leave a comment:


  • 10sec rx7
    replied
    How is a 1in shaft going to go out of balance cutting a piece off the end of it?

    Leave a comment:


  • Dean 560 SEC
    replied
    If you're removing the end of the output shaft wouldn't it need to be machined so it remains balanced? Surely cutting it off with a grinder could potentially cause driveline vibration?

    Any issues since its been installed? How many K's has it been driven?

    Leave a comment:


  • 10sec rx7
    replied
    He chopped it off with a grinder and slid a t400 yoke in

    Leave a comment:


  • Dean 560 SEC
    replied
    Originally posted by ITS60S View Post
    Yep everyone reckons they know and don't get me wrong next to a 4l60 it's a massive fucking cunt of a thing but the bellhousing is the same size and it all seems to fit except one tab i removed. I also lopped off the threaded end and removed the rubber donut from the back of the box as you can run a normal turbo 400 joint off to save room as the donut would have hit the floor, mocking up the stock tailshaft to the t400 joint it eyeball looks ok, I've got another Belair here with a stock motor and box at the moment so I'm planning to double check, just need my 9" finished to get the tailshaft done and see if I am a winner or loser... either way, you won't need a whole commodore floor, massive overkill
    Hey Mate

    Are you able to give me any info on what you did to replace the donut with the turbo 400 yoke/ uni? Im in the process of putting a L98 and 6L80E in to a 1982 XJ6 Jaguar and would prefer to run 1 piece shaft with unit rather than stuff around with the donut at the back of the box.

    Ive read conflicting commentary on which yoke to use, which length, changing seal, not changing seals...is there a simple solution?

    Leave a comment:


  • Dogsballs
    replied
    Oztrack 1/3 racecam

    Sent from my Nexus 6 using Tapatalk

    Leave a comment:


  • Alto
    replied
    Originally posted by ALLMTR View Post
    What cam is that?
    stage 3

    Leave a comment:


  • ALLMTR
    replied
    What cam is that?

    Leave a comment:


  • 10sec rx7
    replied
    Originally posted by 18htan View Post
    How can I be sure that the AFM isn't activated? Fucking AFM badges all over the ute so just assumed it would be running or Holden wouldn't say it was.
    dont fuck around, take it all out... put the same cam as ITS60s and it it has a nice idle with out being over the top etc

    Leave a comment:


  • ITS60S
    replied
    This is the kit you want, sits perfectly over the cross member without hanging too low, just check it works with your mounts

    http://www.ebay.com/itm/Chevrolet-Pe...7/252859153171

    Leave a comment:


  • Dogsballs
    replied
    L77 or L98 had it activated.

    You are stressing over very little. Sump is $150, new cam $500, ls7 lifter $200, valve springs $200. Dalecunt remote tune, few hundred kw bulk?smiles

    Leave a comment:


  • 18htan
    replied
    Originally posted by Dogsballs View Post
    L76 doesnt have it activated though. Will have collapsible lifter but rest isnt there. Any rear sump will work
    How can I be sure that the AFM isn't activated? Fucking AFM badges all over the ute so just assumed it would be running or Holden wouldn't say it was.

    Leave a comment:


  • Dogsballs
    replied
    L76 doesnt have it activated though. Will have collapsible lifter but rest isnt there. Any rear sump will work

    Leave a comment:


  • ITS60S
    replied
    AFM sump has a oil pressure relief valve for the DOD doesn't it?

    Leave a comment:

Working...
X