Announcement

Collapse
No announcement yet.

Wiring fault on my haltech powered car.

Collapse
X
Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Wiring fault on my haltech powered car.

    Hows this for a weird one, went for a drive this afternoon, tagged the limiter out of a corner and the engine just violently died in the arse. Any sort of load and it would missfire and run lean, limed down the road, popped the bonnet, all looked normal, tried driving it again to no avail. Turned it off and on again and its fixed, car ran fine but 10 minutes later did the same thing, this time wouldnt rev over 3000rpm (thought the cable was fucked at first).....

    Turn it off and on and its fixed, drove home and parked it....
    Either I'm having some weird electrical issues (wideband MTXL flashes E9 every no and then under WOT) or something is fucked. Are these things known for doing weird shit?

    Have recently fixed a bunch of boost leaks, new timing belt and oil pump but I cant see the connection

    #2
    not normally.. it will normally be something else that's fucked. fuel pump, reg, sensor etc..
    im a cunt
    and apparently i dont know shit...

    Comment


      #3
      More likely to be a fucked earth strap or corroded fusible link than the ecu.

      Comment


        #4
        Originally posted by Nathan Tinkler View Post
        More likely to be a fucked earth strap or corroded fusible link than the ecu.
        The MTXL throwing an E9 code on WOT (every now and then) certainly points to something being screwy.

        Comment


          #5
          Double post
          GURU ENGINEERING PTY LTD

          Comment


            #6
            Haltech go into some kind of Limp mode when they get a power spike,( Up or down) Years ago on Open wheelers etc without good Charge systems we used to fit very big Capacitors. Power down and back on again and away they would go.
            GURU ENGINEERING PTY LTD

            Comment


              #7
              Its been running fine today, fuck I hate intermittent faults that rear their head once a blue moon.
              Battery is relocated in the boot, car will crank for ages and I know the power feed is good, I'll have to see if I can find a workshop manual and work out where the factory earth points are and check those.


              Last thing I need is a fire etc

              Comment


                #8
                This cunting thing is rearing its head again, went to WSID, every run, 150ft before the finish just as I grab 5th it dies in the arse, wont rev, limits at 4000~ carrying on etc Power cycle the car, fixed.

                Have driven it around for the past 6 months without issue when doing normal driving, seems to be related to high RPM usage (skids/high RPM pulls)


                Who in western Sydney is good with these fucking things?
                No cunt can tell me anything more than 'hmm maybe an earth' so there is no point me touching it when it might be a hardware/software issue.

                Comment


                  #9
                  E9 is low voltage? Bad earth is my bet.
                  Originally posted by piss98
                  I wish Kochie would get blown out to sea and never found, in fact most of those dumb cunts standing in the rain telling people not to stand in the rain need to get fucked. Stupid tart on the news last night talking to the weather guy "wow you look totally drenched there whateverthefuckhisnamewas." No shit you vapid bitch he is standing in a fucking cyclone.

                  Comment


                    #10
                    Earth's are good
                    Power feeds are good
                    Only thing in the mix is an alarm, turned it off on Wednesday night, no change but I'll be dash diving tomorrow sussing it out, hate aftermarket alarms.

                    Dropped by the shop who tuned it (JEM), as expected, booked solid for eons and Adam wasn't there to rattle a few things to look at off his head.
                    Not sure if the PS2000's logs anything or even what it does if gets bad data from a sensor so I really have no idea, tune is locked so I doubt I would even be able to access anything anyway.

                    Comment


                      #11
                      Borrow a ECU to try?
                      Richard's DatsunZ lappin LakesidZ http://www.youtube.com/watch?v=47OSh...&feature=g-upl

                      “Freedom of speech does not protect you from the consequences of saying stupid shit.”
                      ― Jim C. Hines

                      “Everyone is entitled to his own opinion, but not to his own facts.”
                      ― Daniel Patrick Moynihan

                      “Four hostile newspapers are more to be feared than a thousand bayonets..”
                      ― Napoleon Bonaparte

                      Comment


                        #12
                        Don't know anyone with a PS2000 handy, tune is locked and I need to either do skids or hit the limiter in 4th to replicate the fault.
                        If I could, I would.

                        Before I pay someone I'll rule out the obvious stupid shit.

                        Comment


                          #13
                          Get the tune unlocked and take the car to Dale, fuck locked tunes anyway.
                          Richard's DatsunZ lappin LakesidZ http://www.youtube.com/watch?v=47OSh...&feature=g-upl

                          “Freedom of speech does not protect you from the consequences of saying stupid shit.”
                          ― Jim C. Hines

                          “Everyone is entitled to his own opinion, but not to his own facts.”
                          ― Daniel Patrick Moynihan

                          “Four hostile newspapers are more to be feared than a thousand bayonets..”
                          ― Napoleon Bonaparte

                          Comment


                            #14
                            Ecu can't be locked only the tune, anyone can over write it
                            im a cunt
                            and apparently i dont know shit...

                            Comment


                              #15
                              Put a voltmeter across the coil power supply and go redline it.

                              Comment

                              Working...
                              X