Announcement

Collapse
No announcement yet.

groaning FPR

Collapse
X
Collapse
 
  • Filter
  • Time
  • Show
Clear All
new posts

    groaning FPR

    Left the zed sit for a few months, and now when the FPR groans when it has pressure applied to it. Seems to hold pressure but mostly on idle it has this annoying noise.

    What causes it? and is it actually fkd?

    #2
    Give it a tap with something?
    Originally posted by brewdles
    In short, some cunt at test and tune had a 250cc honda turning to 11ty and it sounded porn. Do that.

    Comment


      #3
      Pretty simple things, just a spring and diaphragm. As above, give it a tap or even pull it apart

      Sent from my HTC One M9 using Tapatalk
      Originally posted by 50RTD
      Dave, have you uploaded the data from the carby?

      Comment


        #4
        Originally posted by Dogsballs View Post
        Pretty simple things, just a spring and diaphragm. As above, give it a tap or even pull it apart
        I have tried touching it up.

        If I block the return line it stops for a seccond or 2.

        I might have to fully remove it and open it up, see what is going on. Was hoping it would be something easy like maybe some air is there and will clear out after awhile.

        Comment


          #5
          Hmm, does sound like air, but usually see a leak as its under pressure. Unless it got some type of vapour from boiling in the rail. Could crack it then

          Sent from my HTC One M9 using Tapatalk
          Originally posted by 50RTD
          Dave, have you uploaded the data from the carby?

          Comment


            #6
            Seems to hold pressure. It is like 60 or 70psi idle. no idea why, but thats how it was tuned.

            Noticed Al suggested in the latest version of skid factory to mount on the motor. Currently on the firewall. Might have to move it.

            Comment


              #7
              Originally posted by mad_cow View Post
              Seems to hold pressure. It is like 60 or 70psi idle. no idea why, but thats how it was tuned.

              Noticed Al suggested in the latest version of skid factory to mount on the motor. Currently on the firewall. Might have to move it.
              My Aeromotive groaned for a while after doing the fuel rail. I put it down to air trapped inside. After a couple of days it went away.

              Comment


                #8
                This has not gone away. Even after some solid driving. Besides pulling it apart to look at im running out of ideas.

                Comment

                Working...
                X